$re = '/\[(\w+):\s?(\w+.\w+)]/';
$str = '[img: something.jpg]';
$subst = "<$1 src='$2' />";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;