$re = '/^(\b)?([0-9]{9,11})(\b)?$/';
$str = '102056571
1020565710
10205657100
102056571000
10205657';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);