using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([NSEW])?(-)?(\d+(?:\.\d+)?)[°º:d\s]\s?(?:(\d+(?:\.\d+)?)['’‘′:]\s?(?:(\d{1,2}(?:\.\d+)?)(?:""|″|’’|'')?)?)?\s?([NSEW])?";
string input = @"W59 12’ 70.7’’N 02 15’39.6’’N";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}