use strict;
my $str = 'RENATa T. GROCHAL';
my $regex = qr/(.+)\s(\S+)$/p;
my $subst = '$2, $1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";