$re = '/(?<propName>[A-Za-z0-9_.-]+)(?<assign>\s*(?:=|:)\s*)(?<propVal>(?:[^\r\n\\\\]++|\\\\(?:\r?\n|\r|.))*+$)/m';
$str = 'DAOSomething.classe
=
com.theCompagny.theProject.theFeature.dao.\\
impl.DAOSomethingImpl
channel = bla\\
bla \\
bla
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);