# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(\d{2})_(\d{4})\b/$2_$1/gm;t' <<< "02_2024.pdf"