package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(\d{2})_(\d{4})\b`)
var str = `02_2024.pdf`
var substitution = "$2_$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}