# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\/(.*(?<!friends)(?<!friends\\/))\?.*$/$1/gm;t' <<< "/friends?guest=1&event=chill_out&submit=2
/friends/?more_params
/friend/?more_params
/friend?more_params"