use strict;
my $str = '/friends?guest=1&event=chill_out&submit=2
/friends/?more_params
/friend/?more_params
/friend?more_params';
my $regex = qr/\/(.*(?<!friends)(?<!friends\/))\?.*$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";