$re = '/^([A-Za-z]+|[A-Za-z]+\s[A-Za-z]+)$/m';
$str = 'Some String
some string
some
string
strin1
string string2
M3
M n';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);