$re = '/(?<=~\s\[)([a-zA-Z0-9\.]+)(?::)[^]]+/';
$str = '3 INFO ~ [com.Engine:164] italics';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);