package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\d{1,3}(?:,\d{3})*(\.\d{1,2})?$`)
var str = `12,125.25`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}