using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<Trigger R=""In a burst of feathers, a portal appears!"" SD=""DUCK PORTAL DUCK PORTAL DUCK PORTAL"" ST=""3"" CR=""F"" C=""Thalumbra Duck Portal"" T=""F"" TN="" Ta=""F"">";
string substitution = @"warn ${Player}";
string input = @"\#FFFF00Jessip Daggerheart is attempting to sneak up on Aditu, but they haven't noticed... You should warn them!
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}