import re
regex = re.compile(r"<Trigger R=\"In a burst of feathers, a portal appears!\" SD=\"DUCK PORTAL DUCK PORTAL DUCK PORTAL\" ST=\"3\" CR=\"F\" C=\"Thalumbra Duck Portal\" T=\"F\" TN=\"\" Ta=\"F\">", flags=re.MULTILINE)
test_str = ("\\#FFFF00Jessip Daggerheart is attempting to sneak up on Aditu, but they haven't noticed... You should warn them!\n")
subst = "warn ${Player}"
result = regex.sub(subst, test_str)
if result:
print(result)