#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(\d+)x\d+(?:,\d+)?)?\d+(k?g|g|m?l)"
Local $sString = "0,5g" & @CRLF & _
"500l" & @CRLF & _
"1000kg" & @CRLF & _
"20,5ml" & @CRLF & _
"20x0,50l (1 l = 1,70 €) zzgl. 3,10€ Pfand"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")