package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(\d+)x\d+(?:,\d+)?)?\d+(k?g|g|m?l)`)
var str = `0,5g
500l
1000kg
20,5ml
20x0,50l (1 l = 1,70 €) zzgl. 3,10€ Pfand`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}