#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".*[^\t\s]=[^\t\s].*" & @CRLF & _
""
Local $sString = "x=something" & @CRLF & _
"if(y==x)" & @CRLF & _
"if(y <=x)" & @CRLF & _
"if(y>=x)" & @CRLF & _
"if(y!=x)" & @CRLF & _
"x = something" & @CRLF & _
"x=something" & @CRLF & _
"x = something"
Local $sSubst = " = "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)