use strict;
my $str = 'x=something
if(y==x)
if(y <=x)
if(y>=x)
if(y!=x)
x = something
x=something
x = something';
my $regex = qr/.*[^\t\s]=[^\t\s].*
/p;
my $subst = ' = ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";