$re = '/.*[^\t\s]=[^\t\s].*
/';
$str = 'x=something
if(y==x)
if(y <=x)
if(y>=x)
if(y!=x)
x = something
x=something
x = something';
$subst = " = ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;