import Foundation
let pattern = #"""
.*[^\t\s]=[^\t\s].*
"""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
x=something
if(y==x)
if(y <=x)
if(y>=x)
if(y!=x)
x = something
x=something
x = something
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" = "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)