import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n"
+ " (?:\n"
+ " (?:[0-6]?\\d|70)(?:-[0-6]?\\d|70)?\n"
+ " )\n"
+ " (?:\n"
+ " ,(?:[0-6]?\\d|70)(?:-[0-6]?\\d|70)?\n"
+ " )*\n"
+ "$";
final String string = "10,20-30,35-40\n"
+ "70-50\n"
+ "50\n"
+ "500\n"
+ "40-50,50-60,5,50\n"
+ "40-50,6555\n"
+ "5-50\n"
+ "5,80\n"
+ "8,71\n"
+ "test and lol\n"
+ "08,60\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}