package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s(\d\S*)\s`)
var str = `scsm 7.2.4.8023 LogRhythm System Monitor Agent for AIX`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}