package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[-+]?[0-9]+(?:,[0-9]{3})*(?:\.[0-9]+)?$`)
var str = `3200
3,200
3,200.00
3,2,3,6,5,6.2
3,223,334,643,544,446.2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}