// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(([a-zA-Z]{2}|[0-9]{2})[0-9]{6})?$").unwrap();
let string = "ab123456
12345678
aa441236
aw222222";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}