import Foundation
let pattern = #"[client <HOST>;] user .*; not found: \/phpmyadmin\/|[client <HOST>;] user root: authentication failure for "\/phpmyadmin\/":"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Jun 20 00:06:51 mail dovecot: auth-worker(12786): sql(marchwinska@womczest.edu.pl,14.99.33.34,<cmoeqCXFQ6kOYyEi>): Password mismatch"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}