#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*[.-](?=[.-]))[^.-][a-z0-9.-]{1,61}[^.-]$"
Local $sString = "abc-123.xyz" & @CRLF & _
"abc123-.xyz " & @CRLF & _
"123456789012345678901234567890123456789012345678901234567890123" & @CRLF & _
"" & @CRLF & _
"1234567890123456789012345678901234567890123456789012345678901234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")