const regex = /^(?!.*[.-](?=[.-]))[^.-][a-z0-9.-]{1,61}[^.-]$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*[.-](?=[.-]))[^.-][a-z0-9.-]{1,61}[^.-]$', 'gm')
const str = `abc-123.xyz
abc123-.xyz
123456789012345678901234567890123456789012345678901234567890123
1234567890123456789012345678901234567890123456789012345678901234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}