$re = '/^(?!.*[.-](?=[.-]))[^.-][a-z0-9.-]{1,61}[^.-]$/m';
$str = 'abc-123.xyz
abc123-.xyz
123456789012345678901234567890123456789012345678901234567890123
1234567890123456789012345678901234567890123456789012345678901234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);