# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\w.*solarwinds.orion\\(solarwinds.*|swjobengine.*|netflowservice.*|counterfetcher.*)\.exe$"
test_str = ("// Explanation\n"
"// Matches all files part of the \"orion\" folder that start with solarwinds,swjobengine,netflowservice,counterfetcher and ends with \".exe\"\n\n"
"// Some Solarwinds exe starting with \"solarwinds.\"\n"
"e:\\program files\\solarwinds\\orion\\solarwinds.orion.logmgmt.syslogservice.exe\n"
"e:\\program files\\solarwinds\\orion\\solarwinds.businesslayerhostx64.exe\n"
"e:\\program files\\solarwinds\\orion\\solarwinds.orion.logmgmt.syslogservice.exe\n"
"e:\\program files\\solarwinds\\orion\\solarwinds.collector.service.exe\n"
"e:\\program files\\solarwinds\\orion\\solarwinds.orion.logmgmt.pollingservice.exe\n"
"e:\\program files\\solarwinds\\orion\\solarwinds.businesslayerhost.exe\n"
"e:\\program files\\solarwinds\\orion\\solarwinds.orion.logmgmt.trapservice.exe\n"
"e:\\program files\\solarwinds\\orion\\solarwinds.recommendations.service.exe\n"
"e:\\program files\\solarwinds\\orion\\solarwinds.informationservice.servicev3.exe\n"
"e:\\program files\\solarwinds\\orion\\solarwinds.highavailability.service.exe\n"
"e:\\program files\\solarwinds\\orion\\solarwinds.servicehost.process.exe\n"
"e:\\program files\\solarwinds\\orion\\solarwinds.topology.calculator.exe\n\n"
"// Example with another drive\n"
"C:\\program files\\solarwinds\\orion\\solarwinds.topology.calculator.exe\n\n"
"// Some Solarwinds exe NOT starting with \"solarwinds.\"\n"
"e:\\program files\\solarwinds\\orion\\netflowservice.exe\n"
"e:\\program files\\solarwinds\\orion\\swjobengineworker2.exe\n"
"e:\\program files\\solarwinds\\orion\\swjobenginesvc2.exe\n"
"e:\\program files\\solarwinds\\orion\\swjobengineworker2x64.exe\n"
"e:\\program files\\solarwinds\\orion\\counterfetcher.exe\n\n"
"// Non Orion folders\n"
"c:\\program files\\common files\\solarwinds\\administrationservice\\solarwinds.administration.exe\n\n\n"
"// TESTS\n"
"e:\\program files\\solarwinds\\orion\\solarwinds.exe\n"
"e:\\program files\\solarwinds\\orion\\solarwinds.test.exe\n"
"e:\\program files\\solarwinds\\orion\\solarwinds.test.test2.exe\n\n"
"Without orion folder\n"
"e:\\program files\\solarwinds\\NotOrion\\solarwinds.servicehost.process.exe\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.