using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b
(
(?<abrev>(?:[A-Z]\.)+)
|(?<roman>M{0,4}(?:CM|CD|D?C{0,3})(?:XC|XL|L?X{0,3})(?:IX|IV|V?I{0,3}))
|(?<prep>(?i)d?[aoe]s?(?-i))
|(?<first>\w)(?<rest>\w+)
)
\b";
string substitution = @"${abrev}${roman}\L${prep}\E\U${first}\L${rest}";
string input = @"alto dO cruzeiro
joão paulo II
N.S. aparecida
N.S. DAS GRAÇAS";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace | RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}