re = /\bwith\s+(?!\P{P}*\bwith\b)(\P{P}+)/
str = 'This is a test with a string with punctuation, and an end. Then test words, and more text. And here whith more text with more punctuation, like that.
It should also work with a sentence finishing by a dot.
And what do we do with fruits? such as apples, pears and lemons?
Please come with this stuff:
- your laptop.
- a block of paper.
- a pencil.
I would not recommend sun bathing with just some oil!
I don\'t think you want to match "with" if it\'s in a string.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end