$re = '/\\\\(?<log_name>\w+\.\w+)$/m';
$str = 'blah\\blah\\blah\\logs\\error.log
blah\\blah\\blah\\logs\\audit.log
blah\\blah\\blah\\logs\\utility.log
blah\\blah\\blah\\logs\\service.log
blah\\blah\\blah\\logs\\servlet.log';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);