Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
{"comments":".*","country":"[A-Z]{2}","ctyhocns":\[\S*\],"emailAddress":"\S*","homeAddress":".*","name":{"firstName":".*","lastName":".*"},"phoneNumber":".*","relationshipWithHilton":{"contractorSupplierVendor":(true|false),"formerTeamMemberId":".*","gymOrSpaMember":(true|false),"hhonorsNumber":".*","hotelVisitor":(true|false),"other":(true|false),"registeredHotelGuest":(true|false),"teamMemberId":".*","unregisteredHotelGuest":(true|false)},"request":{"access":(true|false),"correct":(true|false),"get":(true|false),"object":(true|false),"remove":(true|false),"requestComments":".*","restrict":(true|false),"withdraw":(true|false)},"requestForSomeoneElse":(true|false)}
/
gm
Input 1
1
New