const regex = new RegExp('^(\\d+\\.\\d+)\\.([1-9])', 'gm')
const str = `1.01.1
1.01.2
1.01.3
1.02.1
1.02.01`;
const subst = `\1.0\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);