use strict;
my $str = '1.01.1
1.01.2
1.01.3
1.02.1
1.02.01';
my $regex = qr/^(\d+\.\d+)\.([1-9])/mp;
my $subst = '\\1.0\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";