re = /^(\d+\.\d+)\.([1-9])/m
str = '1.01.1
1.01.2
1.01.3
1.02.1
1.02.01'
subst = '\\1.0\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result