$re = '/^(?:[0-9]|[12][0-9]|3[01])$/m';
$str = '0
1
2
3
4
5
6
7
8
9
10
11
19
20
21
29
30
31
32';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);