using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(CN=)(.*?)(?<!\\),.*";
string input = @"CN=Lastname\, FirstName,OU=org,OU=Unit,DC=Domain,DC=com
CN=1234567,OU=org,OU=Unit,DC=Domain,DC=com
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}