#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\(\s*[0-9]+\)\[[a-zA-Z0-9\s:]*\|\s*[0-9]{1,5}\:[0-9]{3}\s*(?:\[[0-9]{1,3}\:[0-9]{1,3}\])?\]\{[0-9]{1,4}\}[a-zA-Z0-9\s:@\/~]+\(?:.+\)[\$|#]\s{1}(?<!\n)(.+)$"
Local $sString = "( 8)[Thu Sep 01 09:44:38| 0:000]{157}jhyland@jhmac:~(✓)$ whoami" & @CRLF & _
"( 8)[Thu Sep 01 09:44:42| 0:000]{158}jhyland@jhmac:~(✓)$ uptime" & @CRLF & _
"( 8)[Thu Sep 01 09:44:45| 1:000]{159}jhyland@jhmac:~(✓)$ pwd Documents/scripts/" & @CRLF & _
"( 8)[Thu Sep 01 09:44:51| 1:000]{160}jhyland@jhmac:~(✓)$ false" & @CRLF & _
"( 8)[Thu Sep 01 09:44:54| 0:000]{161}jhyland@jhmac:~(123)$ d" & @CRLF & _
"( 8)[Thu Sep 01 09:44:38| 0:000]{157}jhyland@jhmac:~(✓)$ whoami" & @CRLF & _
"( 8)[Thu Sep 01 09:44:42| 0:000]{158}jhyland@jhmac:~(✓)$ uptime" & @CRLF & _
"( 8)[Thu Sep 01 09:44:45| 1:000]{159}jhyland@jhmac:~(✓)$ pwd Documents/scripts/" & @CRLF & _
"( 8)[Thu Sep 01 09:44:51| 1:000]{160}jhyland@jhmac:~(✓)$ false" & @CRLF & _
"( 8)[Thu Sep 01 09:44:54| 0:000]{161}jhyland@jhmac:~(0)$" & @CRLF & _
"( 7)[Thu Sep 01 09:17:30| 1:000]{1}jhyland@jhmac:~(✓)$ man idk" & @CRLF & _
"( 7)[Thu Sep 01 09:17:32| 2:000]{2}jhyland@jhmac:~(0)$ man file" & @CRLF & _
"( 7)[Thu Sep 01 09:50:51| 1998:000 [00:33]]{3}jhyland@jhmac:~(✓)$ " & @CRLF & _
"( 7)[Thu Sep 01 09:54:08| 0:000]{1}jhyland@jhmac:~(✓)$ . ~/.bash_profile" & @CRLF & _
"( 7)[Thu Sep 01 09:54:14| 0:000]{2}jhyland@jhmac:~(✓)$ return_code" & @CRLF & _
"( 7)[Thu Sep 01 09:54:17| 0:000]{3}jhyland@jhmac:~(0)$ sudo su -" & @CRLF & _
"( 7)[Thu Sep 01 10:05:49| 0:000]{1}root@jhmac:~(✓)# whoami" & @CRLF & _
"( 7)[Thu Sep 01 10:06:24| 0:000]{2}root@jhmac:~(✓)# cd ~" & @CRLF & _
"( 7)[Thu Sep 01 10:06:29| 0:000]{3}root@jhmac:~(✓)# cd /tmp" & @CRLF & _
"( 7)[Thu Sep 01 09:54:08| 0:000]{1}jhyland@jhmac:~(✓)$ . ~/.bash_profile" & @CRLF & _
"( 7)[Thu Sep 01 09:54:14| 0:000]{2}jhyland@jhmac:~(✓)$ return_code" & @CRLF & _
"( 7)[Thu Sep 01 09:54:17| 0:000]{3}jhyland@jhmac:~(0)$ sudo su -" & @CRLF & _
"( 7)[Thu Sep 01 10:05:49| 0:000]{1}root@jhmac:~(✓)# whoami" & @CRLF & _
"( 7)[Thu Sep 01 10:06:24| 0:000]{2}root@jhmac:~(✓)# cd ~" & @CRLF & _
"( 7)[Thu Sep 01 10:06:29| 0:000]{3}root@jhmac:~(✓)# cd /tmp" & @CRLF & _
"( 7)[Thu Sep 01 10:06:33| 0:000]{4}root@jhmac:/tmp(✓)# cd ~/.ssh/" & @CRLF & _
"( 7)[Thu Sep 01 10:15:35| 0:000]{5}root@jhmac:~/.ssh(✓)# exit" & @CRLF & _
"( 7)[Thu Sep 01 10:15:39| 591:000 [00:09]]{4}jhyland@jhmac:~(✓)$ cd Documents/scripts/javascript/" & @CRLF & _
"( 7)[Thu Sep 01 10:15:44| 0:000]{5}jhyland@jhmac:~/Documents/scripts/javascript(✓)$ ls"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")