import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\(\\s*[0-9]+\\)\\[[a-zA-Z0-9\\s:]*\\|\\s*[0-9]{1,5}\\:[0-9]{3}\\s*(?:\\[[0-9]{1,3}\\:[0-9]{1,3}\\])?\\]\\{[0-9]{1,4}\\}[a-zA-Z0-9\\s:@\\/~]+\\(?:.+\\)[\\$|#]\\s{1}(?<!\\n)(.+)$";
final String string = "( 8)[Thu Sep 01 09:44:38| 0:000]{157}jhyland@jhmac:~(✓)$ whoami\n"
+ "( 8)[Thu Sep 01 09:44:42| 0:000]{158}jhyland@jhmac:~(✓)$ uptime\n"
+ "( 8)[Thu Sep 01 09:44:45| 1:000]{159}jhyland@jhmac:~(✓)$ pwd Documents/scripts/\n"
+ "( 8)[Thu Sep 01 09:44:51| 1:000]{160}jhyland@jhmac:~(✓)$ false\n"
+ "( 8)[Thu Sep 01 09:44:54| 0:000]{161}jhyland@jhmac:~(123)$ d\n"
+ "( 8)[Thu Sep 01 09:44:38| 0:000]{157}jhyland@jhmac:~(✓)$ whoami\n"
+ "( 8)[Thu Sep 01 09:44:42| 0:000]{158}jhyland@jhmac:~(✓)$ uptime\n"
+ "( 8)[Thu Sep 01 09:44:45| 1:000]{159}jhyland@jhmac:~(✓)$ pwd Documents/scripts/\n"
+ "( 8)[Thu Sep 01 09:44:51| 1:000]{160}jhyland@jhmac:~(✓)$ false\n"
+ "( 8)[Thu Sep 01 09:44:54| 0:000]{161}jhyland@jhmac:~(0)$\n"
+ "( 7)[Thu Sep 01 09:17:30| 1:000]{1}jhyland@jhmac:~(✓)$ man idk\n"
+ "( 7)[Thu Sep 01 09:17:32| 2:000]{2}jhyland@jhmac:~(0)$ man file\n"
+ "( 7)[Thu Sep 01 09:50:51| 1998:000 [00:33]]{3}jhyland@jhmac:~(✓)$ \n"
+ "( 7)[Thu Sep 01 09:54:08| 0:000]{1}jhyland@jhmac:~(✓)$ . ~/.bash_profile\n"
+ "( 7)[Thu Sep 01 09:54:14| 0:000]{2}jhyland@jhmac:~(✓)$ return_code\n"
+ "( 7)[Thu Sep 01 09:54:17| 0:000]{3}jhyland@jhmac:~(0)$ sudo su -\n"
+ "( 7)[Thu Sep 01 10:05:49| 0:000]{1}root@jhmac:~(✓)# whoami\n"
+ "( 7)[Thu Sep 01 10:06:24| 0:000]{2}root@jhmac:~(✓)# cd ~\n"
+ "( 7)[Thu Sep 01 10:06:29| 0:000]{3}root@jhmac:~(✓)# cd /tmp\n"
+ "( 7)[Thu Sep 01 09:54:08| 0:000]{1}jhyland@jhmac:~(✓)$ . ~/.bash_profile\n"
+ "( 7)[Thu Sep 01 09:54:14| 0:000]{2}jhyland@jhmac:~(✓)$ return_code\n"
+ "( 7)[Thu Sep 01 09:54:17| 0:000]{3}jhyland@jhmac:~(0)$ sudo su -\n"
+ "( 7)[Thu Sep 01 10:05:49| 0:000]{1}root@jhmac:~(✓)# whoami\n"
+ "( 7)[Thu Sep 01 10:06:24| 0:000]{2}root@jhmac:~(✓)# cd ~\n"
+ "( 7)[Thu Sep 01 10:06:29| 0:000]{3}root@jhmac:~(✓)# cd /tmp\n"
+ "( 7)[Thu Sep 01 10:06:33| 0:000]{4}root@jhmac:/tmp(✓)# cd ~/.ssh/\n"
+ "( 7)[Thu Sep 01 10:15:35| 0:000]{5}root@jhmac:~/.ssh(✓)# exit\n"
+ "( 7)[Thu Sep 01 10:15:39| 591:000 [00:09]]{4}jhyland@jhmac:~(✓)$ cd Documents/scripts/javascript/\n"
+ "( 7)[Thu Sep 01 10:15:44| 0:000]{5}jhyland@jhmac:~/Documents/scripts/javascript(✓)$ ls";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}