using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\d{3}.*|([\w\+$#/\\]{6,})";
string input = @"pass12p
pass125p
asdfasf12asdf34
asdfasf12345asdf34";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}