re = /.*\d{3}.*|([\w\+$#\/\\]{6,})/
str = 'pass12p
pass125p
asdfasf12asdf34
asdfasf12345asdf34'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end