// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*\d{3}.*|([\w\+$#/\\]{6,})").unwrap();
let string = "pass12p
pass125p
asdfasf12asdf34
asdfasf12345asdf34";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}