#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/\*([^\*]|\*[^\/])*\*\/"
Local $sString = "pre comment /* inside comment */ and ouside comment /* inside /* comment */ and this is outside --> */" & @CRLF & _
"You can even group several lines /*" & @CRLF & _
"" & @CRLF & _
"As in this comment" & @CRLF & _
"that spans several lines" & @CRLF & _
"" & @CRLF & _
"*/" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")