#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?m)^(?=(?:.*type:([^/\s]+))?)(?=(?:.*sort:([^/\s]+))?).*"
Local $sString = "xbox/type:article/sort:date-desc" & @CRLF & _
"nintendo/type:media/sort:comments-asc" & @CRLF & _
"nintendo/type:1987/sort:14" & @CRLF & _
"pc/sort:views-desc" & @CRLF & _
"playstation/type:opinion/" & @CRLF & _
"playstation/sort:views-asc" & @CRLF & _
"xbox/sort:views-asc/type:article" & @CRLF & _
"playstation/type:media/sort:views-asc" & @CRLF & _
"xbox" & @CRLF & _
"" & @CRLF & _
"02:52:00 P1D" & @CRLF & _
"y1987 m8 d13 02:52:00 P1D"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")