# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?m)^(?=(?:.*type:([^/\s]+))?)(?=(?:.*sort:([^/\s]+))?).*"
test_str = ("xbox/type:article/sort:date-desc\n"
"nintendo/type:media/sort:comments-asc\n"
"nintendo/type:1987/sort:14\n"
"pc/sort:views-desc\n"
"playstation/type:opinion/\n"
"playstation/sort:views-asc\n"
"xbox/sort:views-asc/type:article\n"
"playstation/type:media/sort:views-asc\n"
"xbox\n\n"
"02:52:00 P1D\n"
"y1987 m8 d13 02:52:00 P1D")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.