#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z]{2,3}([-\/][a-zA-Z]{2,3})?$"
Local $sString = "XX" & @CRLF & _
"XXX" & @CRLF & _
"XX-XX" & @CRLF & _
"XXX-XX" & @CRLF & _
"XXX-XXX" & @CRLF & _
"XX-XXX" & @CRLF & _
"" & @CRLF & _
"XX/XX" & @CRLF & _
"XXX/XX" & @CRLF & _
"XXX/XXX" & @CRLF & _
"XX/XXX"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")