import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?sm)^[^\\n]+(?=\\r?\\nflimflam)";
final String string = "foobar\n"
+ "blahblah\n"
+ "flimflam\n"
+ "zimzam\n"
+ "blahblah\n"
+ "zimzam";
final String subst = "new stuff";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}