package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:^\[FOR\](\w+)=(\d+).(\d+))|(?:\[NEXT\]((?1)))`)
var str = `[FOR]FUNCO=1,99
Id funzionario per esempio #ID_FCCOD#
[NEXT]FUNCO
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}