re = /(?:^\[FOR\](\w+)=(\d+).(\d+))|(?:\[NEXT\]((?1)))/
str = '[FOR]FUNCO=1,99
Id funzionario per esempio #ID_FCCOD#
[NEXT]FUNCO
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end